Elevated latency and error rate

Incident Report for ImageKit.io

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 17:45 IST

Monitoring

We are continuing to monitor the issue. System latency has returned to normal.
Posted Sep 08, 2025 - 17:33 IST

Identified

The issue has been fixed.
Posted Sep 08, 2025 - 17:33 IST

Investigating

We have identified the issue and fixing it.
Posted Sep 08, 2025 - 17:30 IST
This incident affected: Image Transformation - SGP Region, Image Transformation - MUM Region, Image Transformation - EU Region, Image Transformation - US West Region, and Image Transformation - AUS Region.