Slow image response time in Mumbai region

Incident Report for ImageKit.io

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 13:55 IST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2025 - 13:48 IST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 26, 2025 - 13:28 IST

Investigating

The response times from our image servers in Mumbai region is currently high. The incident is being investigated. We will follow up with updates soon.
Posted Nov 26, 2025 - 13:12 IST
This incident affected: Image Transformation - MUM Region.