Video delivery and processing service degrade

Incident Report for ImageKit.io

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:28 IST

Monitoring

we are monitoring the issue.
Posted Oct 20, 2025 - 16:28 IST

Identified

Fix was implemented and we are monitoring the issue.
Posted Oct 20, 2025 - 16:28 IST

Investigating

Video delivery service was impacted because of the aws outage.
Posted Oct 20, 2025 - 16:15 IST
This incident affected: Video Delivery and Processing.