Image Delivery and upload service degrade

Incident Report for ImageKit.io

Resolved

The incident has been resolved.
Posted Oct 20, 2025 - 15:54 IST

Monitoring

Fix has been pushed and error rates has come down. We are monitoring the status.
Posted Oct 20, 2025 - 15:28 IST

Identified

The issue has been identified and fix has been implemented.
Posted Oct 20, 2025 - 14:45 IST

Investigating

We are seeing elevated errors on upload service and high response times for some request on processing service. Issue is because of a major outage from aws impacting various services.
Posted Oct 20, 2025 - 13:30 IST
This incident affected: Image Transformation - SGP Region, Image Transformation - MUM Region, Image Transformation - EU Region, Image Transformation - US East Region, Image Transformation - US West Region, Image Transformation - AUS Region, Fast Upload API, and Video Delivery and Processing.