We are working on to get the delivery domain unblocked. If you are on the premium plan, please get the custom domain configured. On other plans, reach out to our support team at support@imagekit.io
Posted Sep 23, 2026 - 09:14 IST
Investigating
Content delivery using ik.imagekit.io domain is currently blocked in Indonesia. To know alternate domain names for content delivery, please reach out to our support team at support@imagekit.io
Posted Sep 23, 2026 - 07:45 IST
This incident affects: Image Transformation - SGP Region.