Dashboard and upload service down

Incident Report for ImageKit.io

Resolved

This incident has been resolved.
Posted May 30, 2025 - 11:58 IST

Monitoring

The issue has been fixed and we are monitoring.
Posted May 30, 2025 - 11:58 IST

Investigating

We are currently investigating the issue.
Posted May 30, 2025 - 11:46 IST
This incident affected: Imagekit Website & Dashboard, Fast Upload API, and REST API.