Dashboard Service unavailable

Incident Report for ImageKit.io

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 18:12 IST

Update

Issue is fixed. We are monitoring.
Posted Jul 07, 2025 - 18:10 IST

Investigating

We are currently investigating this issue.
Posted Jul 07, 2025 - 18:00 IST
This incident affected: Imagekit Website & Dashboard.